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ENTERPRISE CONSOLE 

CROSS REFERENCE TO RELATED 
APPLICATIONS 

This application claims priority to US. Provisional Patent 
Application Ser. No. 60/457,480, ?led Mar. 24, 2003, Which 
application is incorporated herein in its entirety by this refer 
ence thereto. 

BACKGROUND OF THE INVENTION 

1. Technical Field 
The invention relates to the netWork management technol 

ogy. More particularly, the invention relates to an enterprise 
console for management of large-scale the netWorks of com 
putational devices. 

2. Description of the Prior Art 
Information technology (IT) administrators in enterprises 

everyWhere face a daunting task of managing the softWare 
and hardWare on tens, hundreds, or thousands of machines in 
their domains. With so many incompatibilities, patches, and 
policy advisories announced daily, the task is much more than 
just acquisition and installation. Even simply keeping aWare 
of all potentially problematic situations on hardWare and 
softWare products used in an enterprise requires more than a 
full-time job. Dealing With those situations in response to user 
complaints adds still further taxing demands. Thus, it is 
required that IT managers must anticipate the situations 
Which may soon arise in a speci?c enterprise and make plans 
to deal With those before they cause major problems. This 
creates an urgent need of a technique Which enables the IT 
managers to understand the con?guration of the hardWare and 
softWare in a given intranet, to keep track of the policy advi 
sories, updates, incompatibilities and patches relevant to the 
speci?c enterprise, and to match those policy advisories, 
updates, and patches With the speci?c equipment in the enter 
prise. 

Donoho et al disclose in US. Pat. No. 6,256,664 a tech 
nique Which enables a collection of computers and associated 
communications infrastructure to offer a neW communica 
tions process. This process alloWs information providers to 
broadcast information to a population of information con 
sumers. The information may be targeted to those consumers 
Who have a precisely formulated need for the information. 
This targeting may be based on information Which is inacces 
sible to other communications protocols because, for 
example, under other protocols the targeting requires each 
potential recipient to reveal sensitive information, or under 
other protocols the targeting requires each potential recipient 
to reveal information obtainable after extensive calculations 
using data available only upon intimate knoWledge of the 
consumer computer, its contents, and local environment. 

This process enables ef?cient solutions to a variety of 
problems in modern life, including the automated technical 
support of modern computers. In the technical support appli 
cation, the disclosed invention alloWs a provider to reach 
precisely those speci?c computers in a large consumer popu 
lation Which exhibit a speci?c combination of hardWare, soft 
Ware, system settings, data, and local environment, and to 
offer the users of those computers appropriate remedies to 
correct problems knoWn to affect computers in such situa 
tions. 

FIG. 1 is a schematic block diagram illustrating a commu 
nications system for computed relevant messaging according 
to the prior art. A user directs an advice reader running on his 
computer 101 to subscribe to three advice provider sites 103 
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2 
105. The corresponding advice is brought into his computer 
in the form of digital documents, Where the advice reader 
inspects the advisories for relevance. These digital documents 
are called advisories. The transfer from Internet 102 to com 
puter is entirely one-Way. No information about the user’s 
machine goes back to the advice provider. An advice typically 
comprises three parts: (1) a relevance clause Written in rel 
evance language Which is evaluated by the advice reader to 
determine the relevance of the advice; (2) a message body for 
providing explanatory material explaining to an advice con 
sumer as to What condition is relevant, Why the advice con 
sumer is concerned, and What action is recommended; and (3) 
an action button for providing the advice consumer With the 
ability to invoke an automatic execution of a recommended 
action. 

Whereas in the consumer setting it is acceptable for the 
computer user to be in control of the process, learning Which 
problems exist and applying the ?xes, in the enterprise setting 
it is often the case that end user administration of computers 
is froWned upon. Instead, computers are often managed cen 
trally, and a system administrator is in charge of keeping 
con?gurations Workable and avoiding enterprise-Wide prob 
lems. 
What is desired is a technique that provides centraliZed 

advice management in a large-scale the netWork of comput 
ers. 

What is further desired is that such technique provides a 
management interface that can display relevant advisories of 
all computers in the netWork and deploy suggested actions to 
all relevant computers. 
What is still further desired is that such management inter 

face alloWs a system administrator to manage subscription of 
advice provider sites, monitor status of deployed actions and 
monitor status of computers in the netWork. 
What is still further desired is that such technique can 

automatically apply the required management tasks to ?x 
problems on susceptible machines before they occur. 
Commonly assigned PCT application no. PCT/US02/ 

3 6644, Which application is incorporated herein in its entirety 
by this reference thereto, discloses a system and method for 
centraliZed advice management of large-scale the netWorks, 
Wherein a number of distributed clients run on registered 
computers, gathering advisories and report relevance to a 
central server. A system administrator may vieW the relevant 
messages through a management interface and deploy sug 
gested actions to distributed clients Where the actions are 
executed to apply the solutions of the advisories. 

In a preferred embodiment, a centraliZed advice manage 
ment system includes a plurality of distributed clients, a cen 
tral server, a central database, and a management interface. 
The distributed clients gather advisories from a plurality of 
advice provider sites and report relevance of advisories to the 
central server. A system administrator may vieW the details of 
relevant advisories and deploy the suggested actions to dis 
tributed clients of relevant computers, Where the actions are 
executed to apply solutions provided by the advisories. 

In another equally preferred embodiment, a centraliZed 
advice management system includes a plurality of distributed 
clients, a mirror server, a central server, a central database, 
and a management interface. 

In another equally preferred embodiment, a centraliZed 
advice management system having a distributed client is pro 
vided, in Which the distributed client comprises various com 
ponents performing functions such as gathering advisories, 
authenticating advisories, evaluating relevance of advisories, 
registering a computer to a central server, reporting relevance 
to the central server, listening messages from the central 
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server, gathering deployed actions from the central server, 
and executing deployed actions. 

In another equally preferred embodiment, a method for 
providing centraliZed advice management for large-scale 
computer the netWorks is disclosed that comprises the steps 
of: 

The distributed clients on the computers register to a cen 

tral server; 
A system administrator subscribes registered computers to 

advice provider sites; 
The distributed clients gather advisories from subscribed 

advice provider sites; 
The distributed clients report relevance to the central 

server; 
The system administrator vieWs relevant advisories using a 
management interface; 

The system administrator deploys actions suggested by the 
advisories to the distributed clients; and 

The distributed clients execute the deployed actions to 
apply the solutions of the advisories. 

The method may further comprise a step to manage sub 
scription of advice provider sites to the distributed clients. It 
may further comprise a step to monitor the status of deployed 
actions. Alternatively, it may further comprise a step to moni 
tor the status of registered computers. 

It Would be advantageous to provide an enterprise console 
by Which such system is used to identify vulnerable comput 
ers on the network, and that then alloWs authorized personnel 
to correct problems across any subset of the netWork With a 
feW simple mouse-clicks. 

SUMMARY OF THE INVENTION 

The presently preferred embodiment of the invention com 
prises a console for an enterprise suite. The enterprise suite 
addresses the increasingly complex problem of keeping criti 
cal systems updated, compatible, and free of security holes. It 
uses Fixlet® technology to identify vulnerable computers on 
the network and then alloWs authoriZed personnel to correct 
problems across any subset of the netWork With a feW simple 
mouse-clicks. The enterprise suite helps keep the netWorked 
computers updated and properly patched, all from a central 
console Which, along With supporting architectural enhance 
ments, is the subject matter of this document. The invention 
alloWs rolling out a security patch in minutes instead of 
months, thus alloWing an administrator to stay ahead of 
potential hacker attacks. The invention also makes it possible 
to track the progress of each computer as updates are applied, 
thus making it simple to gauge the level of compliance across 
the entire enterprise. 

BRIEF DESCRIPTION OF THE DRAWINGS 

FIG. 1 is a schematic block diagram illustrating a commu 
nications system for computed relevant messaging according 
to the prior art; 

FIG. 2 is a block schematic diagram of a system compris 
ing an enterprise console according to the invention; 

FIG. 3 is a screen shot shoWing an enterprise console 
WindoW during a typical session according to the invention; 

FIG. 4 is a screen shot shoWing an enterprise console 
WindoW at the start of a sample session according to the 
invention; 

FIG. 5 is a screen shot shoWing a Fixlet panel during a 
sample session according to the invention; 

FIG. 6 is a screen shot shoWing a Take Action dialog box 
during a sample session according to the invention; 
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4 
FIG. 7 is a screen shot shoWing anAction document during 

a sample session according to the invention; 
FIG. 8 is a screen shot shoWing a ?lter panel and list of 

Fixlet actions a sample session according to the invention; 
FIG. 9 is a screen shot shoWing a Computer document 

during a sample session according to the invention; 
FIG. 10 is a screen shot shoWing a Computer tab ?lter/list 

during a sample session according to the invention; 
FIG. 11 is a screen shot shoWing a Fixlet document during 

a sample session according to the invention; 
FIG. 12 is a screen shot shoWing Fixlet Messages tab 

?lter/list during a sample session according to the invention; 
FIG. 13 is a screen shot shoWing a Console Operator docu 

ment during a sample session according to the invention; and 
FIG. 14 is a screen shot shoWing a Console Operator’s tab 

?lter/list during a sample session according to the invention. 

DETAILED DESCRIPTION OF THE INVENTION 

Glossary 

action passWordiSee signing passWord. 
Action Scripting LanguageiThe language used for crafting 

action scripts. Action can be crafted in different scripting 
languages, including AppleScript and Unix shells. 

ClientiSoftWare installed on each the netWorked computer 
to be managed under. The Client accesses a pool of Fixlet 
messages, checks the computer it is installed on for vul 
nerabilities, and sends the Server a message When such a 
condition occurs. 

ConsoleiA management program that provides an overvieW 
of the status of all the computers With the Client installed in 
the netWork, identifying Which might be vulnerable and 
offering corrective actions. 

databaseiA component of the system that stores data about 
individual computers and Fixlet messages. The Server’s 
interactions primarily affect this database, Which is a stan 
dard Microsoft product (MSDE 2000 or SQL Server 2000). 

Development EnvironmentiAn integrated system for 
authoring and deploying, or publishing, Fixlet messages. 

Enterprise SuiteiA preventive maintenance tool for enter 
prises that monitors computers across the netWorks to ?nd 
and correct vulnerabilities With a feW simple mouse-clicks. 

Fixlet messageiA mechanism for targeting and describing a 
problematic situation on a computer and providing an auto 
matic ?x for it. 

Fixlet serversiWeb servers offering Fixlet site subscrip 
tions. They can be either internal to the enterprise the 
netWork or external to the netWork (if direct extemal We b 
access is alloWed). 

Fixlet siteiA trusted source from Which the Client obtains 
Fixlet messages. 

Generator Install folderiThe directory on the installation 
computer Where the Generator places the installation ?les 
for the system. 

IISiSee Internet Information Services. 
installation computeriA secure computer (separate from the 

Server computer) that hosts and runs the Installation Gen 
erator. 

Installation GeneratoriAn application that creates installers 
for the core system components. 

Internet Information Services (IIS)iis optimiZed to be used 
With a WindoWs 2000 Server computer running IIS. 

Management Rights4Ordinary Console Operators can be 
limited to a speci?ed group of computers. These limits 
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represent the management rights for that user. Only a Site 
Administrator or a Master Operator can assign manage 
ment rights. 

Master OperatoriA Console Operator With administrative 
rights. A Master Operator can do almost everything a Site 
Administrator can do, With the exception of creating neW 
operators. 

mastheadiFiles containing the parameters of the process, 
including URLs that point to Where trusted Fixlet content is 
available. The Client brings content into the enterprise 
based on subscribed mastheads. 

Microsoft Data Engine (MSDE)iA database engine that’s 
included as part of the system and is useful for all the 
reporting and data storage needs. Su?icient for many 
needs, but may be upgraded to a full SQL implementation 
on larger the netWorks. 

Mirror serveriA server required in the system if the enter 
prise does not alloW direct Web access but instead uses a 
proxy server that requires passWord-level authentication. 

MSDEiSee Microsoft Data Engine. 
OperatoriA person Who operates the Console. Ordinary 

operators can deploy Fixlet actions and edit certain com 
puter settings. Master Operators have extra privileges, 
among them the ability to assign management rights to 
other operators. 

RelayiThis is a Client (Win 2k, 2k3 or XP) that is running 
special server softWare. Relays spare server and the net 
Work by minimiZing direct server-client doWnloads and by 
compressing upstream data. Relays are automatically dis 
covered by Clients, Which dynamically choose the Relay to 
connect to. 

Relevance LanguageiThe language in Which relevance 
clauses are Written. 

ServeriA collection of interacting applications (Web server, 
CGI-BIN, and database server) that coordinates the relay 
of information to and from individual computers in the 
system. The server processes may be hosted by a single 
server computer or segmented to run on separate server 

computers. 
signing pas sWordiThe passWord (speci?ed When the system 
Was installed) used by a Console operator to sign an action 
for deployment. It is called the action passWord in the 
Console interface. 

Site AdministratoriThe person in charge of installing and 
authorizing Console operators. 

SQL serveriA full-scale database engine from Microsoft 
that can be acquired and installed into the system to satisfy 
more than the basic reporting and data storage needs. A 
step up from MSDE. 

standard deploymentiA deployment of that applies to Work 
groups and to enterprises With a single administrative 
domain. It is intended for a setting in Which all Client 
computers have direct access to a single internal server. 

system install folderiThe directory on the Server Where the 
Server and related ?les (including Console and Client 
installers) are installed. 

system technologyiA process that enables knowledgeable 
computer technicians to disseminate information about the 
causes of computer problems to Clients across the netWork 
and provide automatic solutions for them. 

ThrottlingiA technique to limit bandWidth to accommodate 
shared users or thin connections. 

VPNiVirtual Private The netWork. An encrypted channel 
(or tunnel) that alloWs companies to extend their local-area 
netWorks across the World by using an inexpensive Internet 
connection. 
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6 
Web ReportsiThese reports can be collected from various 

Servers, providing a Way to centrally administer a set of 
separate the netWorks. 

Discussion 

The Enterprise Suite solves the increasingly complex prob 
lem of keeping critical systems updated, compatible and free 
of security holes. It uses patented Fixlet® technology to iden 
tify vulnerable computers on the netWork and then alloWs 
authorized personnel to correct problems across any subset of 
the netWork With a feW simple mouse-clicks (see US. Pat. No. 
6,604,130, Donoho, et al., issuedAug. 5, 2003 for Relevance 
clause for computed relevance messaging, US. Pat. No. 
6,356,936, Donoho, et al., issued Mar. 12, 2002 for Relevance 
clause for computed relevance messaging; US. Pat. No. 
6,263,362, Donoho, et al., issued Jul. 17, 2001 for Inspector 
for computed relevance messaging; and US. Pat. No. 6,256, 
664, Donoho, et al., issued Jul. 3, 2001 for Method and 
apparatus for computed relevance messaging, each of Which 
is incorporated herein in its entirety by this reference thereto). 
It is easy to keep the networked computers updated and prop 
erly patched, all from a central Console. Rolling out a security 
patch can be accomplished in minutes instead of months, 
alloWing a user to stay ahead of potential hacker attacks, 
viruses and Worms. One is able to track the progress of each 
computer as updates and patches are applied, making it 
simple to gauge the level of compliance across the entire 
enterprise. In addition, the invention keeps a running history 
of all remedial actions, providing a detailed audit trail for 
every Fixlet action and every patched computer on the net 
Work. 

A Typical Installation 
A typical installation of 10,000 or feWer Clients is shoWn in 

FIG. 2. There is a single Server 202 that gathers Fixlet mes 
sages from a Fixlet site 401 on the Internet Where they can be 
vieWed by the Console 206 operator and distributed to the 
Relays 404, 406, Which relay the data on to the Clients 408, 
410. Each Client inspects its local computer and reports any 
relevant Fixlet messages back to the Relays, Which compress 
the data and pass it back up to the servers. The Console 
oversees this activity. It connects to the Server and periodi 
cally updates its display to re?ect changes or neW knoWledge 
about the netWork. When vulnerabilities are discovered, the 
Console operator can then target patches or other ?xes to the 
appropriate computers. The progress of the ?xes can be fol 
loWed in near real-time as they spread to all the relevant 
computers and, one by one, eliminate bugs and vulnerabili 
ties. 

OvervieW of the System 
The system has the folloWing main components: 
The Client is installed on every computer one Wish to 
manage under. It accesses a collection of Fixlet mes 
sages that seek out security holes and other vulnerabili 
ties. If a vulnerability is found, the Client can then imple 
ment corrective actions received from the Console. In 
most cases, the Client operates silently, Without any 
direct intervention from the end user. HoWever, should 
one need to solicit user response, it also alloWs one to 
provide screen prompts. 

The Server is a collection of interacting applicationsiWeb 
server, database server and CGI-BIN programsithat 
lies at the heart of the system. It coordinates the How of 
information to and from individual Clients and stores the 
results in the database. 
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The Relay is an optional component that increases the 
ef?ciency of the system. Instead of letting every the 
networked computer directly access the Server, relays 
can be used to offload much of the burden. Dozens of 
Clients can point to a Relay for downloads, which in turn 
makes only a single request of the server. Relays can 
connect to other relays as well, further increasing the 
e?iciency. They can also automate the relay setup, 
dynamically determining the con?guration for the cur 
rent state of the network. 

The Console ties all these components together to provide 
a system-wide view of the networked computers, along 
with their vulnerabilities and suggested remedies. As an 
authorized user, the Console allows one to quickly and 
simply distribute a ?x to exactly those computers that 
need itiwith zero impact on the rest of the network. The 
Console can be run on any computer that has the network 
access to the Server. 

Web Reports let one produce charts and graphs of data, 
providing one with hard copy and helping one to main 
tain an audit trail of all the Fixlet activity on the network. 
It allows one to export this data for further manipulation 
in a spread sheet or database. The Web Reports program 
also allows one to aggregate information from additional 
Servers that one may have installed in the organization. 
This important feature allows an organization with hun 
dreds of thousands of computers to be quickly and easily 
visualized. 

Introducing the Console 
The Main Console window (see FIG. 3) for the Enterprise 

Suite has an upper panel with four main tabs 301 and a 
document window below that to expand upon each of these 
four key elements of the system. The way to operate the 
Console is to click on one of the four tabs and then double 
click on an item from the resulting list. That opens a document 
in the bottom window with more detailed information about 
the selected item. 

Main Tabs 
Fixlet Messages: Displays a list of Fixlet messages that are 

relevant on the various Client computers on the network. 

Computers: Displays a list of the Client computers on the 
network, along with several useful properties retrieved from 
those computers. 

Actions: Displays a list of the Actions that have been or are 
currently running across the network. Console Operators: 
Displays a list of authorized Console operators. 

Filter Panel: The ?lter panel 302 provides a set of folders 
that contains speci?c ?eld values that one can use to 
narrow down the list panel on the right. For instance, 
after clicking the Fixlet Messages tab, one might open 
the Source Severity folder and select Critical to ?lter the 
list down to critical Fixlet messages only. 

List Panel: The list panel 300 provides a listing, as ?ltered 
by the ?lter panel (above). One can sort the list by 
clicking on the column headers. One can also rearrange 
the headers by dragging them left or right. There may be 
a pop-up menu when one right-click on one of the head 
ers. If so, it contains a list of all the possible ?elds for one 
to select or deselect at will. 

Right-click Menu: The right-click menu 303 is the context 
menu that shows up when one right-clicks on any item in 
a list. Each different list has a unique context menu. 

Document Area: Below the tabbed area is a document 
window. When one double-clicks on an item from any 
list, it opens a detailed document in this area. 
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8 
Document tabs: Each type of document has a unique set of 

document tabs 305 to go along with it. 
Fixlet Message: If a Fixlet message 304 is opened from the 

list, the Fixlet document explains the issue in plain English. 
Action Button: A Fixlet document typically contains at 

least one Action, represented by a link or button 310. Click it 
to deploy the action across the network. 

FIG. 3 is a screen shot from a typical session. 
The Fixlet Messages tab is selected, and the user is viewing 

a message opened from the list panel: In general, the Console 
operator views the list of Fixlet messages, opens each one and 
sees what the issues are. Each Fixlet message describes a 
problem that has been discovered on some Client. The Fixlet 
document in the bottom panel presents one with a short, dear 
explanation of the problem. If one wishes, one can inspect the 
actual code used in the Relevance Expressions and the pro 
posed actions. 
Once one decides to deploy the action to the relevant com 

puters, just click on the action (represented by a button or a 
hyperlink in the Fixlet Window) and follow the prompts. 
After deploying the action, the affected Clients are ?xed and 
no longer report the problem, so the Fixlet disappears. 
One can set preferences that govern how responsive and 

secure one want s Fixlet the network to be. To change the 
default values, select Preferences from the File menu. 

Operating Basics 
The Enterprise Suite is a powerful and feature-packed pro 

gram that may seem overwhelming to a new user. Fortunately, 
once one masters the typical work?ow, the operation 
becomes straightforward and intuitive. Let’s run through a 
sample session: 
1. Start up the Console. 
2. Click the tab labeled Fixlet Messages. One sees two panels, 

side by side (see FIG. 4): The left panel offers a way to ?lter 
the list in the right panel which, in turn, displays all the 
issues that are relevant to the network of computers. 

3. Open up a folder in the ?lter panel (on the left) and select a 
?lter. For instance, open the Source Severity folder and 
click on Critical. The list to the right is now ?ltered to 
display only critical Fixlet messages. 

4. In the right panel, double-click on a Fixlet message of 
interest. A document opens up in the lower panel (see FIG. 
5). This is the text of the Fixlet message. Read the message. 
Typically, one wants to deploy the action recommended by 
the Fixlet message, but it is always wise to read about the 
issue ?rst. 

5. At the bottom of the message one ?nds one or more links 
that initiate actions to ?x the afflicted computers. Click on 
the action that seems most appropriate. A Take Action 
dialog box opens (see FIG. 6). 

6. Use the target tab to select the computers one wishes to 
target. One can simply select the computers one wants 
from the list, which contains all those computers for which 
the Fixlet message is currently relevant. This technique 
limits the Fixlet action to this hardwired list. Or, one can 
select the second button, which allows one to take actions 
on any computers that are currently relevant or become 
relevant in the future. Both options allow one to ?lter this 
group of computers by their retrieved properties. 

7. Use the rest of the tabs to prepare action, including user 
messages, constraints and scheduling, then click the OK 
button. 

8. The Fixlet action is now deployed throughout the network, 
and are applied only to those computers that need it. 
This is the work?ow that one uses for typical computer 

maintenance and remediation. As one explores the interface, 
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one discovers that the invention can also help one inventory 
computers, manage users and maintain a detailed history of 
every patch and upgrade. In each case, one starts With the top 
panel, uses the left panel to ?lter the list and then ?nds further 
information in the bottom panel. With this simple overvieW, 
one is ready to maintain the netWork in prime operating 
condition With a minimum of fuss. 

VieWing Fixlet Messages 
To display a Fixlet message, 
Double-click an entry in any Fixlet list 
The body of the Fixlet message shoWs up in the loWer 

display region (click the Description tab if not already 
selected). All of the Fixlet messages (as Well as computers, 
actions and operators), When selected, get WindoWs of their 
oWn, Which can be managed by selecting items from the 
WindoW menu. 

The Fixlet display region has three tabs: 
Description: typically a rendered HTML (Web) page pro 

viding a descriptive explanation of the problem and an 
action to ?x it. This WindoW also includes the Fixlet 
Message Properties, a panel detailing the code behind 
the Relevance expressions and the Fixlet actions, along 
With other Fixlet properties. By default the properties 
WindoW is turned off. One can turn it on by selecting 
VieW>ShoW Fixlet Message Properties. The message 
body usually has the folloWing elements: 
Graphic elements associated With the speci?c Fixlet site. 
Descriptive content explaining the problem. 
Hyperlinks that specify actions to be taken by the Cli 

ents. 

Hyperlinks that affect the Console or offer metadata 
about the site or the problem. 

Relevant Computers: This is a ?lter/list of all the computers 
targeted by the selected Fixlet message. One can ?lter 
the list by selecting items from the folders on the left, 
and sort the list by clicking on the column headers. 

Action History: This is a ?lter/ list of any actions that have 
been deployed from this Fixlet message. If the Fixlet 
message is neW, there Won’t be any actions in the list. As 
With the other ?lter/lists in the Console, one can ?lter the 
actions using the left panel, and sort them by clicking the 
column headers. 

Monitoring Fixlet Messages 
When Fixlet messages become relevant someWhere on the 

netWork, the invention adds them to the list of Fixlet messages 
to be displayed under the Fixlet Messages tab in the Console 
main WindoW. The Fixlet ?lter/list contains entries that 
include the folloWing information: 
Name: The name assigned to the Fixlet message by the 

author. 
Source Severity: A measure of hoW serious a Fixlet mes 

sage is, assigned by the Fixlet author. Typical values are 
Critical, Important, Moderate or LoW. 

ID: A numerical ID assigned to the Fixlet message by the 
author. 

Site: The name of the site that is generating the relevant 
Fixlet message. 

Affected Computer Count: The number of Clients in the 
netWork currently affected by the Fixlet message. 

Unlocked Computer Count: The number of unlocked com 
puters affected by this Fixlet message. 
Open Action Count: Number of distinct actions open for 

the given Fixlet message. 
Category: The type of Fixlet message, such as a security 

patch or update. 
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10 
DoWnload SiZe: The siZe of the remedial ?le or patch that 

the action doWnloads. 
Source: The name of the source company that provided the 

Fixlet information. 
Source ID: An ID number for the source. 
Source Release Date: The date this Fixlet message Was 

released. 
As With all the ?lter/ lists in the Console, one can ?lter this 

list using the panel of folders on the left. Each folder contains 
data groupings that one can use to narroW doWn the list of 
Fixlet messages on the right. Then, in the listing area itself, 
one can sort the Fixlet messages by clicking a column head 
ing. For example, one might ?lter the list by opening the 
Source Severity folder and selecting Critical to ?lter out non 
critical Fixlet messages. Then one could sort the Fixlet mes 
sages by Affected Computer Count (Which shoWs the number 
of affected computers) to ?nd Which Fixlet messages are 
relevant to the greatest number of computers. If one does not 
see one of the columns listed above, right-click in the Fixlet 
header and select it from the pop-up menu. 

Commenting on a Fixlet Message 
Some Fixlet Sites contain, as part of the Site design, a link 

or button that says Comments. This link is designed to pro 
vide feedback to the Fixlet author. 
1. Find and display a Fixlet message With a “Comment on this 

Fixlet” link. 
2. Click the link. The Fixlet display WindoW broWses to a 
URL, usually to send e-mail or ?ll out a Web form contain 
ing feedback. 

3. Type comments, then send or submit them to the Fixlet 
author. 

Hiding Fixlet Messages 
One can hide a Fixlet message With the folloWing proce 

dure: 
1. From any Fixlet list, select the Fixlet message one Want to 

hide. 
2. Right-click on the Fixlet message and select Hide Fixlet 

from the pop-up menu (or select Hide Fixlet Message from 
the Edit menu). 
The hidden Fixlet message is no longer displayed in the 

Fixlet list. In addition, some Fixlet sites contain, as part of the 
site design, a link that says Hide Fixlet Message. Here’ s What 
to do: 
1. Find and display a Fixlet message With a Hide Fixlet 
Message link or button. 

2. Click on the link or button. 

Generally speaking, it is not necessary to hide Fixlet mes 
sages, as one can simply ignore them. The main reason for 
hiding a Fixlet message is if one feels that the message is not 
relevant to the netWork and could never be useful and one 
Wants to avoid vieWing the message every time one launches 
the Console. 
One can see a list of the hidden Fixlet messages by select 

ing VieW>Hidden Fixlets. From this panel, one can also 
restore or “unhide” a Fixlet message by selecting it and click 
ing the Restore Fixlet button. 

Introducing Relevance 
To inspect various aspects of a computer quickly, the Rel 

evance Language Was developed. This human-readable lan 
guage alloWs Fixlet authors to target actions to just those 
computers that need the ?x and no others. Thus one can feel 
con?dent that only broken machines are being ?xed and that 
the rest are never bothered. 

The Relevance Language can query an exhaustive set of 
computer properties, and it is designed for speed. Most Con 
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sole operators rely on third parties to write Fixlet messages, 
and so their exposure to the Relevance Language is not criti 
cal to operating the Console. However, the Console can be 
customized with short lines of code from the Relevance Lan 
guage (called Relevance Expressions) which allow an 
unprecedented amount of control over the Client computers 
on the network. 

A typical Relevance Expression might be vendor name of 
processor 

This expression returns the name of the manufacturer of the 
CPU (which may be Intel, for instance), which can then be 
used to determine relevance. One can use Relevance Expres 
sions to create retrieved properties which one can use to 
organiZe and ?lter the Clients on the network. For example, 
Table 1 below shows some possible properties that might be 
useful to know about Client computers. 

TABLE 1 

Client Computer Properties 

Property 
name Relevance Expression Result 

Pentium family name of main processor True if the processor 
contains “Pentium” is a Pentium. 

Small Total space of drive “0:” < True if the drive is 
drive 2000000000 smaller than 2 GB. 
Bad clock absolute value (now — apparent True if the clock is 

registration server time) > 1 hour off by more than 
one hour. 

IE ?le version of application Version number of 
Version “iexploreexe” of the registry Internet Explorer. 
Mailto application of key the name of the app 
App “HKEYiCLAS SESiROOThnailto” that handles 

of the registry mailto requests from a 
browser. 

Running exists running application Whose True if Word is 
Word (name of it as lowercase is running on the BES 

“winword exe”) Client computer. 
Bios date date ofBios BIOS date, if it exists. 
Processors number of processors The total number of 

processors in the 
BES Client computer. 

Use the Retrieved Properties dialog to see how these cus 
tom properties work. Click the Add New button, supply the 
property name, and type in the Relevance Expression in the 
text box. There are literally thousands of useful Retrieved 
Propertiesifar too many to list here. 

Viewing Relevance Expressions 
When a Fixlet message becomes relevant to some com 

puter on the network, one may want to know exactly what 
triggered it. One may also want to scrutiniZe the speci?cs of 
the suggested action. One can, because these items are written 
in the Relevance Language, which is a human-readable lan 
guage for probing and acting on computers. 

To view these Relevance Expressions: 
1. Double-click on a Fixlet message from any list to bring up 

a detailed Fixlet document in the bottom window. 

2. Select the Description tab. 
3. Choose View>Fixlet Message Properties. 

This opens a new panel with two main areas to display the 
“brains” behind the Fixlet message: 

the relevance clauses: One or more boxes listing the rel 
evance Expressions that are used to determine the rel 
evance of this Fixlet message. 

The action scripts: One or more boxes showing the code 
that are executed if an action is selected. 

20 

25 

30 

35 

40 

45 

50 

55 

60 

65 

12 
NOTE: This window is always accessible, but it may be 

minimiZed. To open it, grab the vertical divider at the right of 
the screen and drag it left. 

Deploying the Action 
At the heart of the system is the ability to deploy actions to 

?x one or many computers. Here’s how: 
1. Open a Fixlet message from any Fixlet list by double 

clicking it. Read the text carefully, and research the action. 
2. Click the link or button corresponding to the Fixlet action. 
The Take Action dialog box appears. 

3. If one wishes, one can ?ne-tune the list of targeted com 
puters using the Target tab. Use the computer tree in the left 
panel to ?lter the list in the right panel. 

4. Create an optional message to show up on Client computers 
using the Message tab. 

5. Set the various scheduling parameters with the Constraints 
and Execution tabs. 

6. Click the OK button at the bottom of the Take Action dialog 
box. One are asked for password authentication. 

7. Enter the authentication password and click OK. 
The action are sent to all the computers targeted in the Take 

Action dialog. Once the action has executed and the targeted 
computers are ?xed, those computers should no longer report 
this Fixlet message as relevant. 

Monitoring Actions 
When one agrees to take a proposed action he is given 

several options concerning its deploymentifor example, one 
might schedule the action to take place unattended, after 
midnight, or to take place explicitly with computer user 
involvement during the day. After actions have been sched 
uled, the Server attempts to signal individual computers that 
actions are waiting for them. Ideally, the Client gathers the 
action information from the action site and carries it out 
immediately. More typically however, some computers are 
powered off and others are mobile and undocked at the time of 
the deployment. As soon as these computers are powered on 
or docked to the network, the remedial actions are applied to 
them as well. The Console lets one monitor the entire rollout, 
from start to ?nish. 

Click the Actions tab in the main Console window, then 
double-click on an action to view its status, whether 
evaluating, pending, running, ?xed, or failed. 

Stopping an Action 
Should one ever ?nd it necessary to stop execution of an 

action that’s already been deployed but hasn’t ?nished run 
ning yet, follow these steps: 
1. Click on the Actions tab in the main screen. This brings up 

a ?lter/list panel of all current and previous actions. One 
can ?lter or sort them by State or Time Issued to help one 
?nd the action one want to stop. 

2. Right-click on the action and choose Stop Action from the 
pop-up menu. (Or select Stop Action from the Edit menu). 
This removes the action from the Server, whichisubj ect 
to details of a given computer’s the network connectivity 
and gather frequency4quickly terminates the action on 
each computer in the system. 
If one wants to modify an action that’s been deployed but 

hasn’t ?nished running, one must ?rst stop the action as 
described and then start a new action with the desired char 
acteristics. There is no way to modify the targeting or sched 
uling of an action once the deployment is initiated. 

Restarting an Action 
If one has stopped an action before it ?nished, one can start 

it up again with this command: 
Select Restart Action from the Edit menu. 
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This places the action back on the server, Which then begins 
to target the action to the relevant machines. 

Default Actions 
Many Fixlet messages have a default action that can be 

applied automatically. This is a simple process: 
Right-click on a Fixlet message and choose Take Default 

Action from the pop-up menu. Or click on a Fixlet 
message and select Edit>Take Default Action. 

Often, a suite of related Fixlet messages becomes relevant 
all at once. If they each have default actions, one may be able 
to apply all of them With a single click: 
1. Select (using shift- or ctrl-click) the set of Fixlet messages 

one Want to apply. 

2. Right-click on one of the highlighted Fixlet messages and 
choose Take Default Action from the pop-up menu. 

Custom Actions 
One can create custom actions to ?x problems across the 

network that are not currently addressed by the standard 
content sources. Although the process is simple to describe, 
there are an in?nite number of actions and targeting tech 
niques that can be used. To create a custom action: 

Log on to the Console as a Master Operator. 

Select Tools>Take Custom Action. 
The Take Action dialog pops up. 
Click on the Action Script tab and type in an action script. 

For more information on the Action Script dialog, click 
here. 

Click on the Relevance tab if one Would like to ?ne-tune the 
targeting of an action script. 

When one is ready to deploy a custom action, click OK. 
The custom actions are distributed to all the computers 
that have been selected or targeted. 

The actions are applied using Whatever constraints and 
schedules speci?ed. 

Managing Computers 
Monitoring Computer Status 

Although the invention is primarily a preventive mainte 
nance tool, it can also be used to analyZe the computers in the 
netWork. Using the Relevance Language, one can query any 
Client and get a real-time response. This can be invaluable for 
analyZing trends and potential problem areas on the netWork. 
To vieW the computers on the network: 
1. Select the Computers tab in the top panel. One sees a 

?lter/list of the netWorked Client computers, ready to be 
sorted and ?ltered by various computer properties. 

2. Click on folder items (in the left panel) to ?lter the list, 
and/or click on the desired column headers (in the right 
panel) to sort the list. Click again to reverse the sort order. 

The folder names and column headers represent important, 
continuously updated properties of the netWorked computers, 
called retrieved properties. To vieW the Relevance Expres 
sions that de?ne the column headers: 
l . Select De?ne Retrieved Properties from the Tools menu. A 

dialog pops up, initially listing the default properties that 
come prede?ned in the system, such as OS, CPU, Com 
puter Name and so on. 

2. Click on a retrieved property. In the text box underneath, 
one can vieW the Relevance Expressions that are used to 
de?ne this column. For example, the column heading CPU 
is generated by this Relevance Expression: 

(signi?cant digits 2 of (speed of main processor/MHZ)) as 
string & “MHZ” & family name of main processor 
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14 
That is, CPU is a concatenation of relevance expressions 

and strings that produces an output such as: 2800 MHZ Pen 
tium 4. 

3. One may change the prede?ned properties here, but it is 
recommended that one add neW column headings, instead. 

If one changes any of the factory-installed properties, one 
can restore them by re-entering the original relevance expres 
sion. See Restoring Retrieved Properties. One can quickly 
select Which properties to display by right-clicking on the 
column headers. A pop-up menu is displayed that alloWs one 
to check or uncheck the properties one Wants to display. 
Notice that When one delete a property from the headers, it 
also disappears from the ?lter panel to the left of the list. 

Creating Retrieved Properties 
One can collect information from Clients by de?ning vari 

ous retrieved properties. An impressive range of computer 
attributes can be monitored as retrieved properties. There are 
several reasons Why one might Want to create some custom 
retrieved properties of oWn: 
Once one create a retrieved property it canbe used as a ?lter 

in all sub sequent computer listings, alloWing one to tame 
datasets that are too large to visualiZe by ?ltering them 
into smaller vieWable chunks. 

NeWly-created properties are added to the column headers 
of computer listings, alloWing one to sort on their values. 

Retrieved properties can be used to ?ne-tune the targeting 
of Fixlet actions. 

Retrieved properties can also be used and charted in Web 
Reports. The preferred embodiment is provided With a 
prede?ned set of retrieved properties Which are sul? 
cient to group computers by many frequently requested 
criteria. There are times, hoWever, When one may Want 
even more control over hoW Clients are grouped and 
sorted. 

To create a custom retrieved property, folloW these steps: 

. Choose Tools>De?ne Retrieved Properties. 

. Click the Add NeW Button. 

. Type in the name of neW retrieved property. 

. Create a Relevance Expression to evaluate. This can access 

hardWare characteristics, registry. 

entries and even data in speci?c ?les on the client computers. 
After one de?ne the neW column heading, the Clients auto 
matically compute the value of the corresponding relevance 
expression and return it to the Database. 
5. Click the OK button. 

Note: Some of these properties are primarily aimed at 
WindoWs computers. Some properties do not Work on certain 
versions of WindoWs and return a blank string. A blank string 
is also returned if more than one result is retrieved for a 
property. 

Restoring Retrieved Properties 
It is easy to customiZe the retrieved properties that are used 

as column headers in all the Console computer listings. 
Should one Want to restore the prede?ned properties, do the 
following: 
1. Visit the Website to select a property de?nition. 

2. From the Console, choose Tools>De?ne Retrieved Prop 
erties. 

3. Select an existing property to edit. 

4. Using the data from the Website, re-enter the proper Rel 
evance Expression into the edit box at the bottom of the 
dialog. 
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5. Click the OK button. 
If one needs to add back a ?eld that one inadvertently 

deleted: 
1. Click on the Add NeW button. 

2. Type in the name of the retrieved property. 
3. Enter the relevance expression as outlined above. 

Locking Computers 
One can change the locked status of any Client in the 

netWork. This lets one exclude speci?c computers or groups 
of computers from the effects of Fixlet actions. This could be 
useful, for instance, if one Wants to insulate certain develop 
ment computers from any changes or updates. It also provides 
a poWerful technique for testing neW Fixlet actions on a 
limited set of unlocked computers, While keeping the rest of 
the netWork locked doWn. Client computers can be locked 
forever (until explicitly unlocked) or for a de?ned period of 
time. 

Changes are made to the locked status of a Client by send 
ing an action. As a consequence, the Console operator must 
supply proper authentication to lock or unlock any computer. 
Even though a Client is locked, there is still a subset of actions 
that can b e accepted by the client. These include clock 
changes and unlock actions as Well as actions from the Sup 
port site. To lock or unlock a computer, folloW these steps: 
1. Click on the Computers tab to bring up the list of the 
netWorked Client computers. 

2. Select the computer(s) that one Wishes to lock. 
3. Right-click and select Edit Computer Settings from the 

pop-up menu. (Or select Edit Computer Settings from the 
Edit menu). 

4. The Edit Settings dialog pops up. Click the checkbox to 
either lock or unlock the computer. 

5. If one are locking the computer, one may also set the 
expiration date and time. This automatically unlocks the 
Client at the speci?ed time. 

Assigning Management Rights 
In a typical deployment, there may be thousands of com 

puters sharing a centraliZed Fixlet database. If they are all 
administered by a single Console, there may be an over 
Whelming amount of information to vieW and the response 
rate may suffer. 
A better Way to organiZe the netWork of this siZe is to break 

it doWn into departments. Each department head can be 
assigned management rights to his oWn departmental com 
puters. For even larger the netWorks, these departments can be 
broken doWn again. Because different managers can be 
assigned to overlapping groups of computers, any kind of 
con?guration is possible. Managers only receive information 
from their assigned computers, dramatically improving 
responsiveness. 

Here’s hoW to grant or revoke management rights: 
1. Log in to the Console as a Master Operator (one must have 

a properly-authorized user name created With the Admin 
istration Tool). If one does not have the proper authoriza 
tion, one is not alloWed to edit management rights. 

2. Click on the Console Operators tab to bring up a ?lter/ list 
of all authorized Operators. (If one does not have the proper 
authorization, this tab is not available). 

3. Right-click on an operator and select Assign User Manage 
ment Rights from the pop-up menu. (Or select Assign User 
Management Rights from the Edit menu). 

4. From the dialog, one can grant speci?c management rights 
to the selected operator. Click the Add button, Which brings 
up a computer ?lter. 
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5. Using retrieved properties as a ?lter, select the desired 

subset of computers one Wishes to have administered by 
this Console operator, and click OK. 

6. One can also revoke management rights using this dialog 
box. Simply click on the Delete button Which brings up 
another computer ?lter. Select the computers one Wants to 
remove from this operator’s administration and click OK. 

7. Click the OK button to ?naliZe the setting. 
Management rights are distributed as Fixlet actions, so one 

sees a brief Action Progress dialog as the neW rights are 
deployed. 
Removing Computers 

To remove a computer from Administration, folloW this 
procedure: 
1. Click the Computers tab and select the computer one 
Wishes to remove. 

2. Right-click on the computer and select Remove Computer 
from the pop-up menu (or select Remove Computer from 
the Edit menu). 
This computer is no longer underAdministration, and is no 

longer be queried for vulnerabilities. 

Managing Fixlet Sites 

Selecting Sites 
Upon installation, is automatically set up to subscribe to 

the Support Site. Depending on the terms of license, one may 
have subscriptions to other sites as Well. This means that 
content from those Sites automatically ?oWs into enterprise 
and are evaluated for relevance on all computers running the 
Client. 

To subscribe to a site, folloW these tWo steps: 
1. First, ?nd an appropriate Fixlet site. Finding a Fixlet site is 

equivalent to ?nding a Fixlet site Masthead ?le, Which has 
an extension of .afxm, .efxm or .fxm. There are several 
Ways to do this: 
Sites: may post links list to neW Fixlet sites as they become 

available. 
Fixlet Subscriptions: Sometimes a Fixlet message might 

offer a subscription. Just click the Fixlet action to initiate 
the subscription. 

DoWnload Mastheads: One can also subscribe to a Fixlet 
site by doWnloading a masthead ?le from a vendor’s 
Web site. Once the masthead is saved to computer, one 
can activate it in one of tWo Ways. 
Double-click the masthead. 
Select Manage Sites from the Tools menu and click Add 

Site. This brings up a standard Open File dialog. Navi 
gate to the saved masthead and select it. 

2. Once one selects a masthead, one is presented With a 
con?rmation dialog. It provides one With information 
about the site. Click Yes to proceed. 

3. One is prompted for private key passWord. Type it in and 
click OK. 
The masthead is propagated to all Clients, Which immedi 

ately begins to evaluate the Fixlet messages from the neW site. 

VieWing Site Properties 
After initiating a subscription, one may Want to inspect its 

properties and signing authorities. This can be useful When 
tracking doWn the origin of a particular Fixlet message or 
action. Here’s how: 
1. Choose Tools>Manage Sites. A dialog box pops up. 
2. Select the desired site from the list. 
3. Click the Properties button. 
The Site Properties dialog box appears, detailing informa 

tion about the site publisher and the precise URLs from Which 
the content has been gathered. Among other things, this dia 
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log box shows e-mail addresses for user feedback and the 
recommended gather frequency. 

Canceling a Subscription 
One can afford to be adventurous in trying out Fixlet Site 

subscriptions for organization, since Fixlet messages them 
selves place no perceptible burden on computers and since no 
actions on those computers are ever taken Without approval. 
Nevertheless, if one ?nds that a subscription is not useful, one 
can cancel it by removing the Site from the list of subscrip 
tions, as follows: 
1. Choose Manage Sites from the Tools menu and, in the 
Manage Sites dialog box, one sees a list of current sub 
scriptions. 

2. Click the name of the Fixlet site one Wants to remove. 
3. Click the Remove Site button. 
NOTE: one cannot unsubscribe from the Support siteiit is 

needed to upgrade and manage licensing issues in the Con 
sole program. 

Using Relays 
Understanding Relays 

Relays are optional the netWork components that can sig 
ni?cantly improve the performance of installation. DoWn 
loads and patches, Which are often large ?les, represent by far 
the greatest fraction of bandWidth. Relays are designed to 
take over the bulk of the doWnload burden from the Server. 
Rather than doWnloading patches directly from a Server, Cli 
ents can instead be instructed to doWnload from designated 
Relays, signi?cantly reducing both server load and client/ 
server the netWork tra?ic. Relays help in the up stream direc 
tion as Well, compiling and compressing data received from 
the Clients before passing it on the Server. Any WindoWs 
2000 or XP-based client can serve as a Relay. 

A Relay simultaneously mitigates tWo bottlenecks: 
Relieves the Load on Servers. The Server has many duties, 
among them the taxing job of distributing patches and 
other ?les. A Relay can be set up to ease this burden, so 
that the Server does not need to distribute the same ?les 
to every Client. Instead, the ?le is sent once to the Relay, 
Which in turn distributes it to the other Clients. The 
overhead on the Server is reduced by the ratio of relays 
to clients. If one has a hundred Clients and one Relay, the 
Server Would only need to process one percent of the 
doWnloads. 

Reduces Congestion on LoW-BandWidth Connections. If 
one has a Server communicating With a doZen comput 
ers in a remote of?ce over a sloW VPN, designate one of 
those computers as a Relay. Then, instead of sending 
patches over the VPN to every Client independently, the 
Server only sends a single copy to the Relay. That Relay, 
in turn, distributes the ?le to the other computers in the 
remote of?ce over its oWn fast LAN. This effectively 
removes the VPN bottleneck for remote groups on the 
netWork. 

Note: Relays also Work Well to reduce total the netWork 
usage When used on subnets connected through sWitches on 
LAN. 

Assigning Relays is simple, and Clients can be made to 
automatically discover and link to them. Automatic discovery 
is recommendedbecause it insures optimal performance even 
While computers and relays are being disconnected and 
reconnected across the netWork. 

Relay Requirements 
A Relay takes over most of the doWnload duties of the 

Server. If several Clients simultaneously request ?les from a 
Relay, a signi?cant amount of the computer’s resources may 
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be used to serve those ?les. Other than that, the duties of the 
Relay are not too demanding. The requirements for a Relay 
computer vary Widely depending on three main factors: 
The number of connected Clients that are doWnloading 

?les. 

The siZe of each doWnload. 

The period of time allotted for the doWnloads. 
The Relay system requirements are similar to those for a 

Workgroup ?le server. A computer With 1 GHZ CPU, 256 MB 
RAM, and 5 GB of free space on the hard drive should be able 
to act as a Relay for several hundred to several thousand 
computersiprovided that the Console operator distributes 
the ?le doWnloads over an appropriate length of time. Here 
are some further requirements and recommendations: 

The Relay can only be installed on computers running 
under WindoWs 2000, 2k3 or XP. 

The Relay can be installed on an ordinary Workstation, but 
if several Clients simultaneously doWnload ?les, it may 
sloW the computer doWn. 

Workgroup ?le servers and other server-quality computers 
that are alWays turned on are good candidates for install 
ing a Relay. 

Secondary Relays 
Although Clients can automatically seek out and connect 

to the available relay, one may Want to control the process 
manually. If so, for each Client in the netWork, one may 
specify both a primary and secondary relay (see FIG. 2). The 
Client ?rst attempts to doWnload any patches from its primary 
relay. HoWever, if the primary Relay is unavailable (because 
the computer has crashed, the hard drive has run out of space, 
the computer is off, etc.), the Clients can doWnload ?les from 
the secondary Relay. 

Relays are failsafe. If the primary Relay fails, the second 
ary kicks in. If the secondary also fails (or no secondary has 
been designated) then the Clients automatically revert to 
doWnloading ?les directly from the Server. Although 
optional, it is recommended that Whenever a Relay is created, 
a secondary Relay should be created as Well. Here’s a useful 
strategy for using the primary and secondary relays: 
One can optimiZe a pair of Relays by splitting the con 

nected Clients into tWo groups of roughly equal siZe. 
One group designates computerA as primary and B as 
secondary. The other group ?ips the order. That cuts the 
overhead of each Relay by tWo, While still providing a 
backup. 

Setting Up A Relay 
To set up a Relay, one needs to designate a WindoWs 2000, 

2k3 or XP client computer to take over some server duties. 
Once a Relay has been set up, computers on the netWork can 
automatically ?nd them and connect to them (or, if one need, 
one can manually assign Clients to point at speci?ed relays). 

This signi?cantly reduces the client/ server communication 
necessary for patch application and management. Clients 
start to doWnload from these designated relays, minimiZing 
the load on thin connections to the Server. The Clients also 
upload their status information to the Relay, Which compiles 
it and compresses it before passing it on up to the server. 

Relays help enormously to spread out and optimiZe the 
netWork traf?c, ensuring maximum responsiveness With 
minimum bandWidth. Relays are especially attractive With 
remote of?ces connected by relatively sloWVPNs. The Server 
sends a single doWnload to the remote Relay, Which can then 
distribute it to the Clients over a faster local subnet. 
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To con?gure a client computer as a Relay, folloW these 4. Check the box labeled Assign Relays Manually. 
Steps? 5 . From the Primary Relay pull-doWn menu, select the desired 
1. Click on the Computers tab in the main WindoW. Relay. 
2. Right-click on a computer from the list to act as the Relay. 6' Click the OK button, 
From the pop-up menu, select Edit Computer Settings. (Or 5 
select Edit Computer Settings from the Edit menu). Viewing Web Reports 

3. Check the box marked Run relay server on this computer. Introducing Web Reports 
4- Click the OK button- The Web Reports can monitor, print or archive the status of 

After the relay has been Created, Clients Can be made to 10 the local database. It also has the ability to read the databases 
automatically discover them and connect up to them, alWays of other Servers and aggregate the data, That offers one a 
seeking the Relay that is the feWest hops aWay. If need to top_level View of a large or far-?ung enterprise with multiple 
manually Con?gure Clients, One must notify each computer database servers. Aggregation servers alloW one to vieW 
that it should use a speci?c relay to point to, as described in information from multiple the networks with hundreds of 
Using Relays. 15 thousands of computers. 
Using Relays Web Reports can be vieWed at any time from the desktop by 

selecting Start>Programs>Enterprise>Web Reports or from 
the Console under Tools>V1eW Web Reports. 
Any Web Report server can be set up to aggregate data from 

the other Servers. 

Once one has set up a Relay one needs to direct Clients on 
the netWork to gather from that relay, instead of from the 
Server. This is actually a good job for a computer, and can 
automatically assign relays for one. This is a good idea for 20 
tWo reasons: 

Clients can determine Which relays are the feWest number 
of hops aWay, so topology is optimiZed. 

The netWork con?guration is constantly shifting as laptops 
dock and undock, as computers start up or shut doWn, or 
as neW hardWare is added or removed. Clients can 

dynamically assess con?guration to maintain the most 
e?icient connections as the netWork changes. 

Web Reports OvervieW 
One can vieW the data in the database from several different 

points of vieW and save or print the output. One may also 
25 export the output to Excel for further manipulation. These 

features are provided by the Web Reports program, Which can 
be run at any time from the desktop by selecting 
Start>Programs>Enterprise>Web Reports or from the Con 
sole by selecting Tools>VieW Web Reports. 

Automatic Relays 30 When one runs the Web Reports program, it presents one 
Here’ 5 how one can ensure that Client Compute;rs are aut0_ With an overvieW of relevant Fixlet messages and remediation 

matically Signing up t0 the nearest relays; efforts. One ?nds charts summarizing the number of admin 
I. Click on the Computers tab to bring up a ?lter/ list of Client lstefefl Computers In the network and vulnerablhty Status‘ In 

computers_ addition, one ?nds overall statistics and a 11st of the most 

2. Select the set of computers that one Want to automatically 35 C? on Issues detected‘ 0.116 can Chck 9n these popular 
Connect to the Optimal Relay‘ Fixlet messages to see them in greater detail. 

3. Right-click the highlighted computers and select Edit At the top of the Screen are ?ve tabs Offering different 

Computer Settings from the pop-up menu. Services:_ 
4_ Check the box labeled Relay Selection Method Overview: The default screen one see When one start up the 

5. Select the button labeled Automatically Locate Relay. 40 Web Reports program‘ 
6_ Click the OK button Stored Reports: Select from a list of previously-‘de?ned 

_ _ _ _ reports. Some commonly-requested reports are built-1n, such 

Manually Assllgnlni-ii l\1/l111lI1Ple Chem? b ) f as 1OperlaltingfSysterlrli Distribution and Vulnerability Trends. 
One can se ect a t e computers or any given su set 0 Se ect t em rom t e top ist. One can create oWn custom 

the local net to gather from the relay. The procedure is differ- 45 reports and save them as either Public or private (vieWable 
ent for setting a single computer or multiple computers. only by one). public reports are added to the top list, private 
Here’s hoW to set multiple computers: reports are only available When one log in With a correct 
1. Click on the Computers tab to bring up a ?lter/ list of Client Password 

COIIIPUIBFS- 50 Create Report: This section alloWs one to create custom 
2. Select the set of computers that one Want to connect to the reports based on Fixlet messages, retrieved properties of 

Relay. Use the ?lter panel on the left to narroW doWn the computers and actions. One can look at all databases, or select 
computer list, if desired. speci?c ones. One can also create custom ?lters and save 

3. Right-click the highlighted computers and select Edit them for other reports. 
Computer Settings from the pop-up menu- 55 Retrieved Properties, including single or multiple proper 

4. Check the box labeled Primary Relay. ties. 
5. Select the name of the desired Relay from the pull-doWn Computers, listed by Status_ 

mlenllg' h b Fixlets, individually or listed by relevance, compliance or 
6. C ic t e OK utton. progress. 

60 . . . . 

Manually Assigning Single Clients Actlons: lndlvldually or by user 
Here’s hoW to set a single computer to point to a relay: Historical, by relevant or aVerage Count. 

1. Click on the Computers tab to bring up a ?lter/ list of Client Settings: This section contains information about the cur 
computers. rently logged-in user, including the type of operator and the 

2. Right-click on the single computer that one Want to connect 65 database Settings for aggregation. 
t0 the Relay- Logout: Click this tab to log out of the Web Reports pro 

3. Select Edit Computer Settings from the pop-up menu. gram. 


















































